Ubuntu Linux 11.04 Natty Narwhal へのアップグレード失敗について

日本時間の4月28日夜にUbuntu Linux 11.04 Natty Narwhal のダウンロード及びアップグレードが可能になったとの通知がupdate-manager経由で知った。早速update-managerを利用しアップデートしたが、

An unresolvable problem occurred while calculating the upgrade: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

というメッセージと共にアップデートが中断する。作業のログは /var/log/dist-upgrade/ 以下にディレクトリが作成されるので、apt.logというファイルを確認する。

  • xserver-xorg関連で大量に「Broken xserver-xorg-core:amd64 Breaks on xserver-xorg-video-8 [ amd64 ] < none > ( none )」などのメッセージが記録されている。

xorg-edgersのppaを利用しているせいだろう。次の作業を行う。

  1. sudo aptitude install ppa-purge
  2. sudo ppa-purge xorg-edgers
  3. sudo aptitude remove libdrm-* libgl1*
  4. sudo aptitude update
  5. sudo aptitude upgrade
  6. sudo do-release-upgrade

これで無事アップデート処理が開始された。

広告